Index of /public/downloads/openafs/Windows 10

[ICO]NameLast modifiedSizeDescription

[DIR]Parent Directory  -  
[DIR]Old-accounts/11-Aug-2017 10:27 -  
[TXT]RestartAFSservice.vbs11-Jan-2017 11:24 791 Clickable script to restart AFS system service if needed
[   ]RestartAFSservice.zip01-Jun-2017 21:53 584 Clickable script to restart AFS system service if needed
[TXT]Windows-K5.html11-Aug-2017 10:15 3.6KInstructions for installing AFS client with Kerberos
[   ]yfs-openafs-en_US-AMD64-1_7_3301.msi21-Feb-2017 14:01 19MMicrosoft Installer file for OpenAFS

New accounts (using RSTOR Kerberos 5)

All Dartmouth AFS accounts created since September 2016 use standard Kerberos 5 authentication, and should use the OpenAFS 1.7.33 installer built by Auristor. In addition, you need the Kerberos libraries and Network Identity Manager, following the instructions in Configuring Kerberos 5 authentication. Some older accounts have also been migrated to K5. If a reinstall is needed, we recommend contacting Research Computing to have your account switched to the Kerberos 5 system, and then use the 1.7.33 installer.
Step-by-step details can be found in Windows OpenAFS with K5

Old Accounts

To reinstall OpenAFS for Windows, for use with an existing accounts (created prior to September 2016) on the legacy authentication server, you must use the OpenAFS 1.7.32 client. You MUST choose Custom Setup when installing, and select the Authentication for AFS optional feature. Do not install the Kerberos packages referenced above. We no longer recommend this version, as it has a problem with recent Windows releases, causing it to lose connectivity to the file servers after a network address change (common with laptops). If this happens, you can use the RestartAFSAFSservice clickable script to stop and restart the service.

The '32-bit-tools' package contains libraries to permit 32-bit programs requiring AFS libraries to run on 64-bit systems. This is not commonly needed at Dartmouth.

If multiple versions are listed above, use the higher-numbered version unless you have a specific reason to need the older one. New versions are added to this list as they are released, and after Computing Services has tested them locally.